Hirdetés

2018. október 22., hétfő

Gyorskeresés

Útvonal

Fórumok  »  OS, alkalmazások  »  Linux kezdőknek (kiemelt téma)

Téma összefoglaló

Téma összefoglaló

  • Utoljára frissítve: 2018-09-25 18:07:40

Mobilarena


Linux kezdőknek

Ez az írás egy hosszabb összefoglaló a kezdők számára, hogy az alapvető dolgokat tisztázzuk, ezzel segítve a kezdők és a kicsit gyakorlottabbak könnyebb haladását.

Még mielőtt nekiállsz az olvasásnak, egy igen fontos dologra felhívjuk a figyelmet!

Amennyiben itt segítséget kérsz valamilyen témában, pár dolgot írj le, így te is hamarabb kapsz értékelhető segítséget. Ezek:

*a disztribúció fajtája, ha van, akkor a verziószáma is. Ha bizonytalan vagy, akkor a terminálos uname -a parancs kimenetét másold be.
*főbb adatok a számítógépről, ha az itteni profil lapodon nem adtad meg őket.
*a probléma részletes és érthető leírása, ha olyan, akkor mellékelt terminál kimenettel. Amennyiben az túl hosszú a bemásoláshoz, akkor feltöltve a pastebin oldalára, majd belinkelve. Ha lenyitod ezt a összefoglalót, akkor konkrét parancsokat mutatunk, amikkel hamarabb kapsz segítséget.


Összefoglaló kinyitása ▼

Hozzászólások

(#701) ngabor2 válasza MikySoft (#700) üzenetére


ngabor2
(PH! nagyúr)

a webkamerával kapcsolatban jó hírem van: [link]

linuxnak reiserfs, vagy ext3 partíciót javasolnék, de telepítéskor úgyis rákérdez. gondolom több helyen olvastad (itt is), hogy nem érdemes 1 nagy partícióra tenni az egész rendszert, mert... nem illik :)
a felosztás nincs kőbe vésve, tapasztalat szerint a /-nek 5-10gb-ot szoktak hagyni (nálam épp 7gb), memóriától függően kb. 1gb swap, a többi pedig maradhat egyben, mint /home, úgyis ide fogsz dolgozni.
arr készülj fel, hogy a win a reiserfs-t/ext3-t max olvasni fogja tudni külső programokkal, de írni nem. nem mintha nem lenne megoldható, de a fejlesztők leírták, hogy nem akarják belevenni, hogy egy ''bizonytalan'' oprendszer egy komoly fs-re írjon, kockáztatva annak épségét.

dc hub tekintetében... leszögezem, nem értek hozzá, csak a google-t használtam. úgy látom, van egy olyan, hogy open dc hub, [link]. ha addig eljutsz, talán egy próbát megér. az biztos, hogy wines hub közvetlenül nem fog futni win alatt. lehet, hogy wine-nal összejönne, de hogy érdemes-e...

[Szerkesztve]

(#702) ragazzo


ragazzo
(őstag)

Üdv. Jelenleg a gépemben két winyó van, az egyiken windows, a másikon pedig mandrake 10.1. Az egész LILO-val indul, itt választom ki, hogy melyiket töltse be. Arra gondoltam, hogy a mandrake-t lecserélem egy UHU-ra, mert nem igazán jött be, és nem jutok vele egyről a kettőre. Itt több kérdés is megfogalmazódott bennem.
1. Magamban mennyire fogok boldogulni, a linux telepítéssel, mert eddig csak xp-t raktam fel, de ott ''csak'' kattingatni kellett.
2. Honnan fogom tudni, hogy a ''jó'' winyóra teszi fel a linuxot, mert nem akarom elbaltázni a windowst.
3. Mivel gondolom reinstallnál törlődik minden, így nem lesz LILO-m, hogyan választom ki, hogy mi bootoljon be bekapcsolásnál?
4. Ha esetleg elrontom a telepítést, attól még fog menni a windowsom?
5. Megoldható-e, és hogyan, ha linuxot akarok futtatni, akkor azt egy telepítő lemezről tegye me (CD vagy kislemez)?

Egyelőre ennyi, előre is köszi a válaszokat a (nektek láma) kérdésekre.

Linux hogyanok kezdőknek közérthetően http://linuxhogyanok.blogspot.com

(#703) PWR válasza ragazzo (#702) üzenetére


PWR
(senior tag)

Hello,

-UHU is elég kattintgatós. Ha jól emléxem csak a partícionálásnál kell szöszölni, ha nem fogadod el azt, amit felajánl alapértelmezetten
-szerintem a win-es vinyót húzd le a telepités idejére, az a legbiztosabb. Különben arra kell csak vigyázni, hgy ne törölj particiót a win-es vinyón és, hogy ne arra telepitsd a boot loadert. Ha a primary master a win-es vinyó, akkor a hda-t hagyd békén (hdb a primary slave, hdc a sec. master..., ha PATA vinyókról van szó)
-az UHU a GRUB boot loadert használja, azt is tutod ugy konfigolni, hogy bootolja az összes oprendszert (win, 10.1, UHU). De ezt megteheted a Mandrake LILO-jával is (szvsz a LILO 1xübb).
-ne is nyúlj a win-es vinyóhoz, akkor minden OK lesz (szedd le, amig a Linuxot telepited)
-szerintem ez 1xübb, ha boot loaderrel csinálod, nem indítólemezzel. De megoldható, pl. kislemezre telepited a boot loadert.

Mandrake-l mik a gondok?

[Szerkesztve]

Üdv

(#704) ragazzo válasza PWR (#703) üzenetére


ragazzo
(őstag)

Jó, akkor tételezzük fel hogy eljutottam az UHU telepítéséig.Onnan hogy rakom fel a LILO-t?Egyáltalán hol találom meg a neten?
A mandrake-val az a gondom, hogy nem igazán hagyja magát még frissíteni sem. Kijelölöm hogy mit kellene, aztán keresgél valamit a neten, majd kiírja hogy még x dolgot fel kellene telepíteni. Rendbent nyomok, aztán meg kiírja hogy nem megfelelő a program azonosítója vagy aláírása (mittudom én mi). A végén csak hibaüzenettel zárul az egész. Már többen írták, hogy próbálkozzak inkább UHU-val, mert ott mégis egyszerűbb az egész, és mégiscsak magyar.

Linux hogyanok kezdőknek közérthetően http://linuxhogyanok.blogspot.com

(#705) ngabor2 válasza ragazzo (#704) üzenetére


ngabor2
(PH! nagyúr)

a telepítő felteszi a lilo-t, rajta van a telepítő-cd-n
a primary master vinyó az a hda, ezen valszeg az első partíción van a win, tehát a hda1-en. az a lényeg, hogy erre ne telepíts. a pri slave vinyó a hdb.

(#706) ragazzo válasza ngabor2 (#705) üzenetére


ragazzo
(őstag)

Ha lehúzom a windowsos winyót, az a legbiztosabb. Összességében akkor nem lehet semmi nehézség a telepítés során, mert az UHU is felismer minden hardvert automatice, és nem kell mindig mountolni a cd és dvd meghajtókat. Mert nekem most így van beállítva. Amennyiben eljutok a LILO-ig, akkor érdemes visszadugni a másik winyót, hogy tudjon választani a szerencsétlen,ugye?Van egy chellom, az is menni fog külön macera nélkül?

Linux hogyanok kezdőknek közérthetően http://linuxhogyanok.blogspot.com

(#707) MikySoft válasza ngabor2 (#701) üzenetére


MikySoft
(tag)

hááát, ha ez ilyen mocerás akkor lehet marad a windows,,, úgí értem...hogy hogyérted hogy nem illik 1 partícióra tenni? nemértem,..:B

(#708) PWR válasza ragazzo (#706) üzenetére


PWR
(senior tag)

telepítés után visszadugod a vinyót és akkor kell belöni a boot loadert. Itt biztos kapsz hozzá segitséget :)

Ja, Mandrake-n, ha nem az adott verzióhoz tartozó csomagot telepitesz, akkor rinyál a digitális aláirás miatt. De attól még felmegy, csak vigyázni kell, pl. ha vmi másik verziójú gcc-t akar feltenni, az bekavarhat. A Mandrake 10.1 supermountot használ, fel kell venni pár sort az fstab fájlba és akkor müxik automatice a mount. Asszem az UHU 1.2 is supermountal van.

Üdv

(#709) ngabor2 válasza MikySoft (#707) üzenetére


ngabor2
(PH! nagyúr)

lehet 1 partícióra tenni, csak ugyebár van, aki a winnek is külön csinál egy pár gb-os partíciót, ha összeomlik, azt fájdalom nélkül formázza, és megy fel rá vissza. ugyanakkor a doksik és a többi cucc egy teljesen más partíción vannak.

linux alatt is ez van, nyugodtan mehet egy partícióra minden, nem lesz tőle lassabb. de ha ''hozzáértőket'' kérdezel meg, mindegik azt fogja ajánlani, hogy külön partíción legyen a /, és a /home. ez ilyen ''beidegződés'', otthoni használatnál nincs igazán jelentősége.

(#710) MikySoft válasza ngabor2 (#709) üzenetére


MikySoft
(tag)

oks, értem, és akkor mehet a WIN is meg a Linux is egyben...:)

(#711) PWR válasza MikySoft (#710) üzenetére


PWR
(senior tag)

Win és Linux lehet egy vinyón de külön partición.

Linux tényleg elmegy 1 partíción de swap-nak (virtuális memoria) azért illik adni külön partíciót, mondjuk 1GB-t.

/home sem árt, ha külön van, mivel igy a felhasználó cuccai külön vannak a rendszertöl. Amúgy ez nem nagy macera, csak nem egy, hanem 3 partíciót kell a telepitésnél csinálni. Az meg többnyire vmilyen grafikus kütyün megy, legördülö listából kell kiválasztani a fájlrendszert meg a csatolási pontot (pl. /home, swap, /) meg beirni a méretet.

Üdv

(#712) ngabor2 válasza MikySoft (#710) üzenetére


ngabor2
(PH! nagyúr)

nálam, és még szerintem sokaknál egyazon gépen van fenn linux és win is. nálam speciel 1.5 linux és egy win van fenn. azért másfél linux, mert az egyiket sikerült elszúrnom, így bootoláson kívül nem sokra képes. a másik alól írok most. a win már jóideje nem rugott labdába, lehet, hogy a köv. linux-telepítés a helyére fog menni.

(az teljesen más dolog, hogy nálam a fontosabb dolgok más partíción vannak, régebben volt 1 wines és 1 linuxos partícióm, úgy is ment. nálad is fog menni, nem nagy ördöngősség, főleg, ha van, aki segít.)

(#713) MikySoft válasza ngabor2 (#712) üzenetére


MikySoft
(tag)

nagyon köszönöm neked és PWR nek is a tanácsokat, információkat! :R

remélem minden jól fog sikerülni,
mert most az van hogy van egy wines part
meg egy másik amin mp3, game, film stb

és akkor most meg megmaradna a 2 partíció, csak lenne még 2 , tehát lenne 4 partíció...

és akkor minden király lesz..:)

(#714) ngabor2 válasza MikySoft (#713) üzenetére


ngabor2
(PH! nagyúr)

és akkor most meg megmaradna a 2 partíció, csak lenne még 2 , tehát lenne 4 partíció...
no ezt akkor most hogyan? :F

(#715) MikySoft válasza ngabor2 (#714) üzenetére


MikySoft
(tag)

Particion Magiccal... azzal elviloeg meglehet, hogy az egyik particióból leszedek valamennyit, és azt egy másik partba rakom be...már volt erre példa az én gépembe..

de erre kevés lesz a 80 gigás vinyóm...valószínű (más okból is) de vennem kell mégegy 80 ast..

1. 80 gigás (2 partició (NTFS) Windows
2. 80 gigás (2 partició (Linux fájlrendszer) ( Linux)


valahogy így nézne ki...

(#716) Batman válasza MikySoft (#715) üzenetére


Batman
(őstag)

Egy kis vinyón is bőven megférnek nekem volt hogy egy 40GB-os hdd-n 3 különböző linux disztro és egy win volt, nem kell túl bonyolítani a dolgot.

A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

(#717) ragazzo


ragazzo
(őstag)

Büszke vagyok magamra. Sikerült leszednem a mandriva-t, és felraknom az UHU-t. Mindezt úgy, hogy működik a Grub, és bejön a win is a másik winyón. Egy lámától szép teljesítmény.Nagyon féltem, hogy elrontok valamit, de csak sikerült. :))
Azért azt nem tudom, hogy miként tudnék létrehozni parancsikont. Ha a telepített könyvtárból kimásolom a parancsfilet, akkor nem csinál semmit. Megkérdezi hogy futtassa vagy mást csináljon. A futtatásra katt, és semmi. Ha áthúzom a parancsfilet, akkor setörténik semmi.

Linux hogyanok kezdőknek közérthetően http://linuxhogyanok.blogspot.com

(#718) MikySoft válasza Batman (#716) üzenetére


MikySoft
(tag)

jaja, igazad van!:)

(#719) cortez25


cortez25
(fanatikus tag)

Felpakoltam egymás mellé win+suse9,3...de a suse bootmanagerét használja a gép, hol tudom állítani a prioritást?

Azért hajtunk, hogy öregségünkre legyen miből visszaállítani az egészségünket, ami ebbe ment tönkre.

(#720) Batman válasza cortez25 (#719) üzenetére


Batman
(őstag)

Mire gondolsz?

A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

(#721) ngabor2 válasza cortez25 (#719) üzenetére


ngabor2
(PH! nagyúr)

milyen boot manager? lilo, vagy grub?
a megfelelő konfigfile-ban (lilo esetén /etc/lilo.conf, frub esetén /boot/grub/menu.lst) kell átírni a default sort.

(#722) cortez25 válasza Batman (#720) üzenetére


cortez25
(fanatikus tag)

csak anni, ugye a bootmanagerben ki tudom választani, hogy melyik op rendszer induljon és elsőnek a linux, másodiknak win, de automatikusan a linux indul. Win ben meg lehet változtatni a prioritást..a linuxban? Hogy mondjuk a Win induljon még bele nem jövök a linuxba...

Azért hajtunk, hogy öregségünkre legyen miből visszaállítani az egészségünket, ami ebbe ment tönkre.

(#723) Batman válasza cortez25 (#722) üzenetére


Batman
(őstag)

ngabo2 megmondta a frankot , a default sort kell átírni pl 0-ról 1-re.

A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

(#724) cortez25 válasza ngabor2 (#721) üzenetére


cortez25
(fanatikus tag)

grub2-es...és akkor mit is kell átírni?

Azért hajtunk, hogy öregségünkre legyen miből visszaállítani az egészségünket, ami ebbe ment tönkre.

(#725) dr_strange válasza cortez25 (#724) üzenetére


dr_strange
(senior tag)

a grub.conf (vagy menu.lst disztribúciótól függően) fájlban egyszerűen a felül lévő bejegyzés lesz a default, tehát ha

title1
.
.
.
title2
.
.
.

van, akkor a title1 indul automatice

JRR Tolkien nyelvei - aglardh.middangeard.org.uk

(#726) emitter


emitter
(őstag)

sziasztok!

ma raktam föl ubuntu-t tökre tetszik :C
egy-két kérdésem lenne:
Firefoxban hogyan lehet átállítani a betűtípust TimseNewromanra? Mert alapból sans serifen van, de ez nem jön be...

Aztán leszedtem a magyar FF 1.5-öt, egy tar.gz csomagban. Kicsomagoltam, oké, mit csináljak vele? Kell fordítani valamit, vagy csak felülírjam vele az 1.07-es FF-ot?

thx :)

(#727) ngabor2 válasza emitter (#726) üzenetére


ngabor2
(PH! nagyúr)

pl. átállítod serif-re. az a times betűtípus.

(#728) emitter válasza ngabor2 (#727) üzenetére


emitter
(őstag)

köszi
és a firefoxszal mit csináljak? :B

(#729) ngabor2 válasza emitter (#728) üzenetére


ngabor2
(PH! nagyúr)

szerkesztés/beállítások, itt általános részen ott vannak a betűtípusok. alapból csak serif és sans serif van. a serif kb. times, a sans pedig kb. arial/helvetica.

(#730) emitter válasza ngabor2 (#729) üzenetére


emitter
(őstag)

nem úgy értettem... a leszedett FF 1.5-öt hogyan tudom installálni, vagy ilyesmi?

(#731) ngabor2 válasza emitter (#730) üzenetére


ngabor2
(PH! nagyúr)

ja, addig nem jutottam olvasásban :D

én (még) nem szedtem le, de az 1.0.x alapján kellene benne lennie egy firefox-installer nevű file-nak. ezt futtatod, és mondja, mit kell csinálni. valószínűsítem, hogy kér egy célkönyvtárat. utána azt a firefoxot kell indítani.

(#732) emitter válasza ngabor2 (#731) üzenetére


emitter
(őstag)

vannak futtatható állományok:
updater
firefox-bin
xpicleanup, stb.

meg van 2 héj-parancsfájl:
firefox
run-mozilla.sh

de az a baj, h egyiket sem tudom futtatni sem duplakatt-tal, sem konzolból :F

(#733) emitter válasza emitter (#732) üzenetére


emitter
(őstag)

up!

(#734) ngabor2 válasza emitter (#732) üzenetére


ngabor2
(PH! nagyúr)

egy ''ls -l '' kimenetet beidézhetnél, talán könnyebb lenne.
gondolom nem olyan partícióra van kicsomagolva, ami a noexec opcióval van felmountolva.

(#735) emitter válasza ngabor2 (#734) üzenetére


emitter
(őstag)

emitter@LAPTOP:~/Letoltesek/firefox$ ls -l
összesen 12693
-rw-r--r-- 1 emitter emitter 218 2005-12-07 18:38 browserconfig.properties
drwxr-xr-x 3 emitter emitter 544 2005-12-07 18:38 chrome
drwxr-xr-x 2 emitter emitter 776 2005-11-12 02:00 components
drwxr-xr-x 5 emitter emitter 128 2005-12-07 18:38 defaults
drwxr-xr-x 5 emitter emitter 184 2005-11-12 01:59 extensions
-rwxr-xr-x 1 emitter emitter 5239 2005-11-12 01:59 firefox
-rwxr-xr-x 1 emitter emitter 9889508 2005-11-12 02:00 firefox-bin
drwxr-xr-x 2 emitter emitter 144 2005-11-12 01:59 greprefs
drwxr-xr-x 2 emitter emitter 176 2005-11-12 01:59 icons
-rwxr-xr-x 1 emitter emitter 563656 2005-11-12 02:00 libmozjs.so
-rwxr-xr-x 1 emitter emitter 176012 2005-11-12 02:00 libnspr4.so
-rwxr-xr-x 1 emitter emitter 426224 2005-11-12 02:00 libnss3.so
-rwxr-xr-x 1 emitter emitter 240360 2005-11-12 02:00 libnssckbi.so
-rwxr-xr-x 1 emitter emitter 15304 2005-11-12 02:00 libplc4.so
-rwxr-xr-x 1 emitter emitter 8240 2005-11-12 02:00 libplds4.so
-rwxr-xr-x 1 emitter emitter 138284 2005-11-12 02:00 libsmime3.so
-rw-r--r-- 1 emitter emitter 476 2005-11-12 02:00 libsoftokn3.chk
-rwxr-xr-x 1 emitter emitter 420964 2005-11-12 02:00 libsoftokn3.so
-rwxr-xr-x 1 emitter emitter 126752 2005-11-12 02:00 libssl3.so
-rwxr-xr-x 1 emitter emitter 94892 2005-11-12 02:00 libxpcom_compat.so
-rwxr-xr-x 1 emitter emitter 687172 2005-11-12 02:00 libxpcom_core.so
-rwxr-xr-x 1 emitter emitter 9240 2005-11-12 02:00 libxpcom.so
-rwxr-xr-x 1 emitter emitter 8284 2005-11-12 02:00 libxpistub.so
-rwxr-xr-x 1 emitter emitter 10336 2005-11-12 02:00 mozilla-xremote-client
drwxr-xr-x 2 emitter emitter 80 2005-11-12 02:00 plugins
-rw-r--r-- 1 emitter emitter 177 2005-11-12 01:59 readme.txt
-rw-r--r-- 1 emitter emitter 256 2005-04-11 23:17 README.txt
-rwxr-xr-x 1 emitter emitter 1538 2005-11-12 01:59 removed-files
drwxr-xr-x 6 emitter emitter 1688 2005-11-12 01:59 res
-rwxr-xr-x 1 emitter emitter 10492 2005-11-12 01:59 run-mozilla.sh
drwxr-xr-x 2 emitter emitter 432 2005-12-07 18:38 searchplugins
-rwxr-xr-x 1 emitter emitter 67496 2005-11-12 02:00 updater
-rw-r--r-- 1 emitter emitter 153 2005-08-25 16:42 updater.ini
-rwxr-xr-x 1 emitter emitter 21368 2005-11-12 02:00 xpicleanup
emitter@LAPTOP:~/Letoltesek/firefox$


egyébként egy partíció van, amin maga a rendszer is van (egy 37G-s), ill. 1.5G swap

(#736) ngabor2 válasza emitter (#735) üzenetére


ngabor2
(PH! nagyúr)

hmmm... nekem elindította a firefox. most próbálgatom, eddig jó.
hogy neked miért nem megy...
próbáld meg a könyvtárában a ./firefox paranccsal. ha ad ki hibát, írd be.

(#737) emitter válasza ngabor2 (#736) üzenetére


emitter
(őstag)

emitter@LAPTOP:~/Letoltesek/firefox$ ./firefox-bin
./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory
emitter@LAPTOP:~/Letoltesek/firefox$ ./firefox
./firefox-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
emitter@LAPTOP:~/Letoltesek/firefox$

akkor vmi lib hiányzik nálam, ami az 1.0.7-eshez nem kellett, de ehhez már kell? :F

(#738) ngabor2 válasza emitter (#737) üzenetére


ngabor2
(PH! nagyúr)

az 1.0.7-hez ezek kellenek:

ngabor@lizard:~/incoming/firefox-installer$ ldd firefox-bin
libmozjs.so => /usr/lib/libmozjs.so (0x40028000)
libxpcom.so => /usr/lib/libxpcom.so (0x400a8000)
libplds4.so => /usr/lib/libplds4.so (0x40195000)
libplc4.so => /usr/lib/libplc4.so (0x40199000)
libnspr4.so => /usr/lib/libnspr4.so (0x4019e000)
libpthread.so.0 => /lib/libpthread.so.0 (0x401d2000)
libdl.so.2 => /lib/libdl.so.2 (0x40223000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x40226000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x404e4000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x40562000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x4057e000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x40593000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x4059a000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x405a5000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x405dc000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x40615000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x40618000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4069b000)
libm.so.6 => /lib/libm.so.6 (0x40762000)
libsmime3.so => /usr/lib/libsmime3.so (0x40784000)
libssl3.so => /usr/lib/libssl3.so (0x407a8000)
libnss3.so => /usr/lib/libnss3.so (0x407cb000)
libsoftokn3.so => /usr/lib/libsoftokn3.so (0x40837000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x408a8000)
libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x408f8000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40900000)
libxpcom_compat.so => /usr/lib/libxpcom_compat.so (0x4090e000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x4092d000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x409e7000)
libc.so.6 => /lib/libc.so.6 (0x409f2000)
libXft.so.2 => /usr/lib/libXft.so.2 (0x40b25000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x40b38000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40b67000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x40bd5000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x40bfb000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40bff000)
libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x40c07000)
libz.so.1 => /usr/lib/libz.so.1 (0x40c0a000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x40c1e000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x40c28000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40c30000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40c39000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40c50000)



az 1.5-höz:

ngabor@lizard:~/incoming/firefox-1.5$ ldd firefox-bin
./firefox-bin: /usr/lib/libnss3.so: version `NSS_3.9.3' not found (required by ./firefox-bin)
libmozjs.so => /usr/lib/libmozjs.so (0x40028000)
libxpcom.so => /usr/lib/libxpcom.so (0x400a8000)
libxpcom_core.so => not found
libplds4.so => /usr/lib/libplds4.so (0x40196000)
libplc4.so => /usr/lib/libplc4.so (0x40199000)
libnspr4.so => /usr/lib/libnspr4.so (0x4019e000)
libpthread.so.0 => /lib/libpthread.so.0 (0x401d2000)
libdl.so.2 => /lib/libdl.so.2 (0x40223000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x40226000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x404e5000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x40562000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x4057e000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x40593000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x4059a000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x405a5000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x405dd000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x40615000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x40618000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4069b000)
libm.so.6 => /lib/libm.so.6 (0x40762000)
libsmime3.so => /usr/lib/libsmime3.so (0x40784000)
libssl3.so => /usr/lib/libssl3.so (0x407a9000)
libnss3.so => /usr/lib/libnss3.so (0x407cb000)
libsoftokn3.so => /usr/lib/libsoftokn3.so (0x40837000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x408a8000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x408b0000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x4091d000)
libxpcom_compat.so => /usr/lib/libxpcom_compat.so (0x4096e000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x4098c000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40a46000)
libc.so.6 => /lib/libc.so.6 (0x40a51000)
libXft.so.2 => /usr/lib/libXft.so.2 (0x40b84000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x40b97000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x40bc7000)
libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x40bed000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40bf1000)
libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x40bf9000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40bfc000)
libz.so.1 => /usr/lib/libz.so.1 (0x40c0a000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x40c1f000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40c28000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40c31000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40c48000)


látható, hogy elég sok lib kell hozzá. úgy tűnik, nálam se talál meg mindent, de működik.
egy

sudo apt-get install libstdc++5

talán segít.

(#739) emitter válasza ngabor2 (#738) üzenetére


emitter
(őstag)

köszi, ez hatásos volt :R
a régi FF-fel mit csináljak? töröljem a könyvtárait? hogyan tudom felülírni az újjal?

(#740) ngabor2 válasza emitter (#739) üzenetére


ngabor2
(PH! nagyúr)

nekem jelenleg kb. 4 verzió van fenn a ff-ból. nem kell törölgetni, elég, ha külön kt-ban vannak.

(#741) emitter válasza ngabor2 (#740) üzenetére


emitter
(őstag)

nekem most a usr/lib/mozilla-firefox mappában levő 1.0.7-es firefox-ot futtatva is az 1.5ös jön be, ez mitől lehet?

Másik kérdés: el tudnátok magyarázni szájbarágósan, hogyan kell felinstallálni ezt a játékot: (innen szedtem le: [link])


[[ Frozen-Bubble ]]


Requirements


SDL_mixer >= 1.2.2
http://www.libsdl.org/projects/SDL_mixer/

SDL perl >= 1.19.0
http://sdlperl.org/

If you compile by hand, double-check you first compile SDL, then SDL_image
and SDL_mixer, then SDL perl, otherwise you might get the error that
NewFont.al is not found.


Installation instructions


[*] First, build Frozen-Bubble and provide the prefix where the
game will be installed (most probably /usr or /usr/local).

make OPTIMIZE=''my_arch_opt_flags'' PREFIX=''my_prefix''


[*] Second, install the files on the system.

- if you're root (case when you build a Debian package, or
when you build it locally on your own machine), you will
choose the same prefix location than for previous step

make install PREFIX=''my_prefix''


- if you're not root (case when you build a RPM package), you
need to install to a temporary directory where you have
write access

make install PREFIX=''/home/my_home/tmp/my_buildroot''

Then an external program such as RPM will collect the
installed files and write the package.



thx :R

(#742) emitter


emitter
(őstag)

a magyar kde-t honnan tölthetem le? csak mert a kde.hu-ról egyik link sem érhető el ''550 Failed to change directory'' :(

(#743) ngabor2 válasza emitter (#741) üzenetére


ngabor2
(PH! nagyúr)

nekem akkor játszott ilyet a ff, mikor valamilyen része ''futva maradt''. pl. a fileletöltés nem lett bezárva, akkor bármit indítottam, az a verzió töltődött be. ha minden be van zárva, akkor nézd meg, hogy nem fut-e mégis valami (ps aux | grep firefox).

ez a játék nincs meg csomagban?
sudo apt-cache search frozen
ha megvan, megkíméled magad egy csomó felesleges szenvedéstől (libeket letölteni, leforgatni, stb).

a kde-t magyarítani a kde-i18n-hu csomaggal lehet. megintcsak a felesleges szenvedés elkerülése végett:
sudo apt-get install kde-i18n-hu

(remélem jól emlékszem, hogy ubuntud van...)

[Szerkesztve]

(#744) cortez25


cortez25
(fanatikus tag)

Linuxra fel!

Szóval kezdjük az alapoknál...suse 9.3...hogyan hozom elő a konzolt? Hogyan telepítem a 6600 Gt-re a drivert? Hogyan telepítem az nf4-es lapra a drivert?

Szóval sík láma vagyok a témához..de szerintem senki nem linuxal a fejében született...mint ahogy én sem...és kitartok... :DDD

Azért hajtunk, hogy öregségünkre legyen miből visszaállítani az egészségünket, ami ebbe ment tönkre.

(#745) ngabor2 válasza cortez25 (#744) üzenetére


ngabor2
(PH! nagyúr)

no akkor kezdjük az alapoknál :D
szigorúan személyes, igen kis mintán végzett nem-reprezentatív megfigyelésem alapján legnehezebben a suse-sok kapnak választ speciális kérdéseikre. legjobban az ubuntusok. talán nem véletlen, a suse egy teljesen egyedi irányt követ, csak az alapok a linuxos dolgok. az ubuntu viszont teljesen kompatibilis akar maradni a debiannal, ami a legelterjedtebb, leginkább karbantartott disztribúció. tehát ha még nem merültél bele teljesen a suse-ba, és van rá lehetőséged, akkor inkább válts ubuntura. no ennyit a propagandáról és az agitációról :DDD

konzol előhozása: ctrl-alt-f1. de ez nem elég, ha a graf. kártya driverét akarod telepíteni, ahoz a kdm-et is le kell lőni: root-ként:

/etc/rc.d/kdm stop


a graf. kártya telepítése: jobb disztribekben benne van csomagként az nvidia driver. ha nincs, akkor angolul ott a readme...
nf3 lapom van, nem igazán kellett külön driver, elég volt az, ami a kernelben benne van gyárilag.

tarts ki, az első hetek elég... hmmm... érdekesek lesznek, de aztán nem fog hiányozni a win ;)

(#746) akasp


akasp
(senior tag)

gyors help kéne: hogy lehet egy windows-os ill. egy suse linuxos gépet összehozni?

(#747) Batman válasza akasp (#746) üzenetére


Batman
(őstag)

Felrakod Windowst!
Majd csinlász egy üres particot , legyen mondjuk 10Gb így bőségesen felfér rá a Suse-d és még lessz helyed is.
Majd berak a Suse teleptő elindít, értelemszerűen válaszolsz a kérdésekre nem nehéz.
A megadod neki a particot ahova akarod rakni, ez lessz a ''/'', majd 250-512 vagy akármennyi swap-ot , 512Mb bőven elég.
Mikor rákérdez ,hogy az MBR-t hova írja megadod neki azt a hdd-t ami a biosban be van állítva, amiről bootol a gép.

Ennyi.
üdv
Batman

A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

(#748) emitter


emitter
(őstag)

hali!

leszedtem a hálózati nyomtatómhoz egy drivert (ugye jól gondolom, h kell a linuxos gépemre is driver, nem csak a windózos célgépre?)
lexmark a márka, de az alapból támogatott printerek között nem volt ez a típus

a leszedett file egy tarball, benne egy ''z600cups-1.0-1.gz.sh'' nevű cucc
ezt futtatva ezt kapom:

''emitter@LAPTOP:~/Letoltesek/Lexmark$ sh z600cups-1.0-1.gz.sh
Verifying archive integrity...OK
Uncompressing Lexmark Printer Drivertrap: usage: trap [-lp] [arg signal_spec ...]
''



ez most akkor mit csinált? készvan, vagy még kell vmit konfigolnom :F
hogyan tudom a nyomtatót használni? (ubuntum van)

thx :)

(#749) cortez25 válasza ngabor2 (#745) üzenetére


cortez25
(fanatikus tag)

köszi ! de suse-t kaptam....ubuntut nem...tehát ez van ezt kell szeretnem...nézegettem a yast-ot meg a sax-ot de pl a yast-ban benne van egy csomó nvidia driver de nem tutam beletenni sehol a 6600 gt-ét. leszedtem ezt a honlapról NVIDIA-Linux-x86_64-1.0-7676-pkg2.run...de mit is kell vele csinálni?

Azért hajtunk, hogy öregségünkre legyen miből visszaállítani az egészségünket, ami ebbe ment tönkre.

(#750) emitter válasza cortez25 (#749) üzenetére


emitter
(őstag)

hát elvileg kell lennie hozzá valami readme-nek, abban leírva a telepítés lépései...
ha ilyen nincs, akkor próbáld meg konzolból futtatni:
elnavigálsz a mappába, ahova letöltötted, ott ''./NVIDIA-Linux-x86_64-1.0-7676-pkg2.run'' és akkor ha minden ok, elindul a telepítője :U

Útvonal

Fórumok  »  OS, alkalmazások  »  Linux kezdőknek (kiemelt téma)
Copyright © 2000-2018 PROHARDVER Informatikai Kft.